Find us on Facebook Follow us on Twitter Check out our YouTube Channel
    • SUBSCRIBE

    ves valves 03 PRO-X 700

    2802 views
    2 replies
    1 rating 2 rating 3 rating 4 rating 5 rating
    • Member since
      October 2006
    ves valves 03 PRO-X 700
    Posted by boodab71 on Thursday, January 18, 2007 7:55 AM
    I just pulled my valves out for cleaning they were a bit gummy after 800 miles.  After I reinstalled them for whatever reason I noticed that there is a bit of air coming out the holes in the covers.  Is this normal or did I do something wrong?Hmm [^o)]
    • Member since
      July 2005
    Posted by jasper on Thursday, January 25, 2007 5:01 PM
    Shouldn't be any leaks. I'd double check the bellows for any tears. Be sure they are sealing properly,even around the valve shafts. Might want to make sure you installed the bellows washer correctly also, seen some guys installl them upside down.
    • Member since
      January 2007
    Posted by Experts on Thursday, February 1, 2007 10:37 AM
    You could have a pin hole in the bellows, but there will be some air forced out the hole from valve movement. If it has air coming out at idle, you should disassemble check for a hole and most likley you will need to replace the bellows.

    Join our Community!

    Our community is FREE to join. To participate you must either login or register for an account.

    Sign up for our free newsletter
    By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our Privacy Policy.

    Users Online

    There are no community member online
    More great sites from Kalmbach Publishing Co.