Find us on Facebook Follow us on Twitter Check out our YouTube Channel
    • SUBSCRIBE

    2003 ski doo mxz x 800

    469 views
    1 replies
    1 rating 2 rating 3 rating 4 rating 5 rating
    • Member since
      October, 2016
    2003 ski doo mxz x 800
    Posted by BadBoy72 on Sunday, October 16, 2016 12:10 PM

    I have 2003 ski doo 800 recently put a brand new motor in on my first trip out after my 100 mile brake in the pull cord assembly broke apart leaving parts everywhere from it also shutting my sled down on the trail leaving my gauges stuck at 70 mph and 4500 rpm. I cleaned out all the debris the magneto and the stater seemed to be on good shape didn't see any damage to either put new pull cord assembly in yesterday and sled doesn't seem to want to fire??

    Tags: 2003 mxz x
    • Member since
      July, 2005
    Posted by dyna-tek racing on Wednesday, October 19, 2016 8:01 PM

    You will need to use an ohm meter to verify fitness of the stator and trigger assembly,if it is electric start make sure the battery is fully charged and in good condition.if the electrical relay  hasn't been changed lately I would suggest doing so also ,if you need tech assistance feel free to call,thanks Todd @ dyna-tem performance 

    master mechanic-outboard,sterndrive,pwc,snowmobile. dynamometer facility -crank repair -cylinder repair-trail and race motors-shock service clutch machining and balancing. complete racer support- free technical support-racer discount programs Todd Guthrie 1-260-316-2839 or like us on face book and keep up to date on monthly specials using our facebook page.See new innovative product as soon as it gets built

    Join our Community!

    Our community is FREE to join. To participate you must either login or register for an account.

    Sign up for our free newsletter

    Users Online

    There are no community member online
    More great sites from Kalmbach Publishing Co.