Find us on Facebook Follow us on Twitter Check out our YouTube Channel
    • SUBSCRIBE

    f7 trobles

    825 views
    1 replies
    1 rating 2 rating 3 rating 4 rating 5 rating
    • Member since
      February, 2016
    f7 trobles
    Posted by Docf7 on Sunday, December 11, 2016 4:13 PM

    I started working on my 2006 f7 efi again since we just got snow. The problem is it will go about 60mph now at wide open and sounds like its missing all the time runs and idles good. These are the things I've checked plugs, reeds, power valves, fuel pump fuel pressure, compression, intake leak, injectors cleaned, everything is good. I'm wondering if it could be my stator?

    • Member since
      July, 2005
    Posted by dyna-tek racing on Sunday, January 15, 2017 9:46 PM

    Things to check besides all that you did 1: spark plug cap resistance 2: fuel pump pressure at WOT 3: RPM @WOT 4: leak down on the rings 5: voltage output of the stator at WOT

     

    master mechanic-outboard,sterndrive,pwc,snowmobile. dynamometer facility -crank repair -cylinder repair-trail and race motors-shock service clutch machining and balancing. complete racer support- free technical support-racer discount programs Todd Guthrie 1-260-316-2839 or like us on face book and keep up to date on monthly specials using our facebook page.See new innovative product as soon as it gets built

    Join our Community!

    Our community is FREE to join. To participate you must either login or register for an account.

    Sign up for our free newsletter

    Users Online

    There are no community member online
    More great sites from Kalmbach Publishing Co.