Find us on Facebook Follow us on Twitter Check out our YouTube Channel
    • SUBSCRIBE

    09 dragon 800 updates

    10926 views
    16 replies
    1 rating 2 rating 3 rating 4 rating 5 rating
    • Member since
      January 2010
    09 dragon 800 updates
    Posted by studrb29 on Friday, January 1, 2010 10:18 PM

    Has anyone tested out there 09 dragons after the all the updates were done?   I just bought my 09 dragon 800 seemed to die bog out mid range and top end.  Anyone having the same issues?

    • Member since
      November 2009
    Posted by a1fastxc on Sunday, January 3, 2010 8:41 PM

    YES,,, i was a polaris tech for ten years, and i am very un impressed with the new update kit, it bogs, backfires, has a lean sneeze at 5500 and is waaaaay fat on top, i dunno! its very frustrating!!!!!!!!!!!!!!, i just dont see having to pay 400 bucks, to make this thing run,,, the way it should!. i`ll tell ya polaris is gonna loose alot of money in the long run, from theese issues! "repeat costomers",, my dealer says "everyone is complaining", but again polaris has there heads up there a--!, there probably in florida riding there "hammers"

    • Member since
      February 2006
    • From: wisconsin
    Posted by ZEEKMAN#37 on Sunday, January 3, 2010 10:44 PM
    The '10's run like garbage too!! I've been a Polaris tech for 18 years and it never ceases to amaze me how a company can put out OBVIOUSLY untested equipment to its customers only to have its dealers have to babysit this ***. You can't tell me none of the "engineers"(if you want to call them that)never had an 800 hicup when stabbing the trottle. C'mon guys pull yur heads!!
    JOHN KINNA
    • Member since
      January 2010
    Posted by studrb29 on Sunday, January 3, 2010 10:44 PM

    ya i was out tonight with it and it ran good at times other times it bogged out and top end isnt there......would a power comander help this out?!?!

    • Member since
      February 2006
    • From: wisconsin
    Posted by ZEEKMAN#37 on Sunday, January 3, 2010 10:51 PM
    I don't think a power commander for a STOCK $9,000 sled would be the answer I would want to hear.Piss-poor engineering and testing needs to stop with this company.Polaris needs to get rid of those stupis *** bikes and concentrate on what made them who they are. Shares on NASDAQ arent what they are all cracked up to be.
    JOHN KINNA
    • Member since
      January 2010
    Posted by studrb29 on Sunday, January 3, 2010 11:44 PM

    Looks like i will be making a call this week to slp and getting a major motor upgrade just to keep up with 700 mods......unreal!

    • Member since
      September 2008
    Posted by classic110 on Monday, January 4, 2010 9:30 AM

    Sounds like Polaris has another winner. My 2006 FST was in at the dealer 10+ times for countless updates which never really panned out. For all you 800 owners I know your pain, $9000 is a lot to send for this junk!

    • Member since
      July 2005
    Posted by TRIPLEFLIPPER on Monday, January 4, 2010 1:27 PM

    150 miles on the update and mine is running flawless (touch wood). Only issue I had last year was the stumble and fixed that with irridium plugs and plugging in the ethanol wires. Seems there are good ones and there are bad ones

    • Member since
      January 2010
    Posted by studrb29 on Monday, January 4, 2010 2:24 PM

    I just talked to my dealer here in syracuse and he said to def leave the ethanol wires unplugged.....

    • Member since
      July 2005
    • From: Canada
    Posted by willie on Tuesday, January 5, 2010 12:13 PM

    Around here, 75% of them are going good.

    For the other 25%, after 500 miles, the lean spot at 6000 rpm seems to be difficult to find compare the a sled with a fresh rebuilt engine. 

    I would wait before to tell that the update on those sled is bad.  For the durability issues, I have a customer with 2500 miles now with the update and the engine run like day one.  Last year, we rebuilt the engine twice at that mileage...

    Polaris parts and service manager JG Busque inc. Saint-Georges, QC Canada
    • Member since
      February 2011
    Posted by trail breaker on Sunday, January 10, 2010 8:12 AM

    everytime you fly across a feild with mine ,let off and get back in the throttle the motor back fires, or when taking off for the first time in the morning after letting it warm up, you go 100 yards the motor shuts off then restarts on its own. what ever happened to the phrase polaris used (worlds greastest snowmobile).

    • Member since
      July 2005
    • From: Canada
    Posted by willie on Tuesday, January 12, 2010 3:11 PM

    New reflash for the 800cfi to stop the backfire or little hesitation at mid range. Plus leaner on top.  Dealer are able to do it now.

    Polaris parts and service manager JG Busque inc. Saint-Georges, QC Canada
    • Member since
      February 2006
    • From: wisconsin
    Posted by ZEEKMAN#37 on Tuesday, January 12, 2010 3:17 PM

     Wow,heres another reflash.Theres a shocker.How long do you suppose it will be before they can get this reflash circus to do tricks?

    JOHN KINNA
    • Member since
      February 2011
    Posted by trail breaker on Tuesday, January 12, 2010 8:42 PM

    Is this another reflash, after the new heads, pistons, can and first reflash???????????

    • Member since
      July 2005
    Posted by TRIPLEFLIPPER on Wednesday, January 13, 2010 7:59 AM

    Willie I talked to the Service Manager at my dealer yesterday and he said he had not heard about this. Is there a service bulletin # that you could quote for me

    thanks

    • Member since
      February 2011
    Posted by trail breaker on Monday, February 8, 2010 6:25 PM

    What should the compression be after the rebuild? I checked mine and at wot three pulls it has 105 psi. this seems low.

    • Member since
      November 2018
    Posted by Danimal on Friday, November 30, 2018 12:49 PM

    [quote user="studrb29"]

    Has anyone tested out there 09 dragons after the all the updates were done?   I just bought my 09 dragon 800 seemed to die bog out mid range and top end.  Anyone having the same issues?

     

    i also have a bog below half throttle on my 800cfi comp 105psi on both cylinders im thinking trying seafoam and new plugs for a start also want to try non ethonol fuel and plug wires in  just seems overkill to have to run race fuel on a stock sled since both our gas stations here have ethonol based premium I look forward to more ideas

     

    Join our Community!

    Our community is FREE to join. To participate you must either login or register for an account.

    Sign up for our free newsletter
    By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our Privacy Policy.

    Users Online

    There are no community member online
    More great sites from Kalmbach Publishing Co.