Find us on Facebook Follow us on Twitter Check out our YouTube Channel
    • SUBSCRIBE

    08 IQ 600 LX ECU MELTED DOWN

    2076 views
    3 replies
    1 rating 2 rating 3 rating 4 rating 5 rating
    • Member since
      December 2006
    08 IQ 600 LX ECU MELTED DOWN
    Posted by Catdog on Sunday, January 3, 2010 10:17 PM

    Has anyone else had this issue. Same part number (4011518) for Dragon, Switchback, RMK, IQ, 600, 700, 800 MODELS.

    I have had it less then 2 years should it be under warranty or on re-call?

    I have no idea why it happened.

    • Member since
      July 2005
    • From: Canada
    Posted by willie on Tuesday, January 5, 2010 12:10 PM

    Normaly, this is caused by a faulty regulator.  The grey square part near the ECU. 

    Polaris parts and service manager JG Busque inc. Saint-Georges, QC Canada
    • Member since
      December 2006
    Posted by Catdog on Tuesday, January 5, 2010 4:58 PM

    How can I test the regulator

    • Member since
      January 2008
    Posted by J.L. on Wednesday, January 13, 2010 8:10 PM

    My ecu, spedo pod, regulator & diode all went at the end of Dec. all were replaced by my dealer under the three year warranty that I received when I purchased the machine new. My sled is a 2007 D7 with 6500 miles on the OD when this happened.  The dealer thought that the regulator failed which burnt the other parts.  No recall that I know of. 

     

    Jim Letts

    Join our Community!

    Our community is FREE to join. To participate you must either login or register for an account.

    Sign up for our free newsletter
    By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our Privacy Policy.

    Users Online

    There are no community member online
    More great sites from Kalmbach Publishing Co.